Get in touch
Back
Resolved

PDS access issues

Started , resolved .

dummy.cafe PDS
Resolved

This issue should be resolved now thanks to the emergency maintenance.

Posted .
Created

The PDS started having issues today at approximately 1 AM CEST. We've identified the issue and are working on resolving it.

(This report is backdated to when the downtime started.)

Posted .