Back
Maintenance

More server migrations

Completed .

Chotopia Desktop App update server puyo.xyz
Completed

The server migration is complete

Posted .
Started

The affected services will be intermittently unavailable for a server migration.

Posted .