Back
Resolved

Mastodon outage

Started 17 Sep at 10:59am CEST.

Mastodon server
Created

Mastodon has been down for a bit. It should be back up now, sorry it took so long to fix!

Posted 17 Sep at 10:59am CEST.