Resolved
Safekeeper is now accessible again and has had its storage expanded to 30 GB.
Posted .
Updated
We've identified the issue and have a fix ready.
We're also taking the chance to expand storage space for Safekeeper to prevent further downtime.
Posted .
Created
Safekeeper seems to be unavailable, but is still taking and storing backups fine.
Posted .
Resolved